Leawo iTransfer 1.4.0 All the ideas and discussions
10 votes Vote

let it work with older versions of itunes, atleast to be able to start the app and register

I detest the new version of itunes, and I still would like to use the app for older devices

inifnity, 26.05.2013, 17:48
Idea status: under consideration


Leave a comment